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|| Welcome To The VISDIGS Data Entry System

OVERVIEW:

The VISDIGS Data Entry System is designed to enable you to enter all non-confidential data
collected using the Diagnostic Interview for Genetic Studies (DIGS) into a database.  Each form
and screen in the VISDIGS Data Entry System reflects the pages of the paper version of the
DIGS.  Press the tab key to move your cursor from one field to the next.  Pressing the tab key at
the last field on each page will move the cursor to the Next button.  Press the Next button to
proceed to the next form in the instrument. Or, if you prefer, you can use the Sections Menu
located at the top of the screen in the menu bar to navigate from form to form.  

The VISDIGS system also includes the ability to enter marginal notes from the interview. 
Marginal notes can be entered by clicking the button located on the bottom of each page to the
left of Back button.  See LTo Enter Marginal Notes.  

VISDIGS uses table-level validations to facilitate  accurate data entry. The validation forces the
user to enter data that falls within a specified range or meets a specific value.   For example, the
user will not be able to enter letters in fields where only numbers are permitted.

INSTALLATION

System Requirements

Your computer system must have the following for you to install and successfully run VISDIGS:
200 MHZ
64 MG RAM
Windows 95 or higher operating system
Microsoft Access 2000
15"-17" monitor



User's Guide Page...2

The Visdigs.2.0(2k) is compiled by Microsoft Access 2000.  The program includes only one file
named Visdigs.mde.  After downloading, unzip the file into an empty directory (c:\Newlod is
recommended but not required) in your system.  Your system must have Access 2000.

LInstallation  for those who have already installed previous  version of the program and have
entered data

Before you start the installation process,  be sure to back up your data files.   In order to incorporate
your data into the new release of VISDIGS2.0, follow these procedures:
 1. To rename you old version of the program, say  Old_Visdigs.mde

 2.  To download the new visdigs.mde, and unzip  it into the same directory with Old_Visdigs.mde.

3. To open Visdigs.mde in the edit mode
When prompted for the Database password, enter the password and while holding down the shift
key, either hit the enter key or click the OK button in the password dialog box.

4. To delete the tables in visdigs.mde
In the Database window, press the table button and all the tables will appear. You may delete them
one by one with the delete key.(there is no select all function) 

5.  To Import tables from Old_Visdigs.mde
Click the file item in the MS Access menu bar( the top menu bar),  a drop down menu will be appear.
Click Get external data in the drop down menu, then click  Import. An Import window will be
opened.  Follow the instruction in the window, find the Old_Visdigs.mde, then  click Import button
at the lower right corner of the window, after you enter the  password, the Import Objects window
will appear.  Select all tables in the Old_Visdigs.mde, then click OK; the tables of your old version
now are copied into the new program.

GETTING STARTED

LTo Create VISDIGS Shortcut on Your Desktop

1 Double-click on My Computer on your desktop.

2 Go to NEWLOD folder in your C drive (or the directory you chose).

3 Click once on VISDIGS.MDE to highlight the file.

4 Click on File menu located on the top left corner of the screen. Pull down the menu.

5 Click on Create Shortcut.
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6 Find the icon that reads “Shortcut to VISDIGS.mde” on your desktop.

LTo Start VISDIGS 2.0

Double-click the VISDIGS.mde to start the program.

After the password “Washington” is entered, the following screen appear:

LTo Add a New Record
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1 Click the New Record button on the Search/Add Form screen.

2 The cursor will be placed in the Site ID field; enter the Site ID.  Enter all required information in
the fields that are below the Site ID field.  The VISDIGs system requires a Site ID, Subject ID,
Family ID, Mother ID, and Father ID for every subject. These sizes (number of digits) for each ID
are specified as following:

Name of ID Number of digits

Site ID 2

Subject ID 5

Family ID 3

Mother ID 5

Father ID 5

 Pressing the Tab key or Enter key on the keyboard will place the cursor on the next field where the
information needs to be entered.  Note:  the family ID will appear automatically.  

3 Press the Add button located directly below the Father ID field.  

The DIGS Only button is to be used for subjects that already have a Pedigree record entered.  The
idea was that many pedigrees would be entered, then many related DIGS records would be
completed.  The DIGS only button is used by entering a valid subject_id (ie. pedigree record for that
subject exits AND a DIGS record for that subject does not) in the enabled subject_id field
and then pressing the Add button to Add the DIGS records.  If the subject_id is valid, the user should
be taken to the first DIGS data entry screen.
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VISDIGS will ask you a series of questions to find out exactly where you would like to add the new
record. Your choices are:

“Add to BOTH the Summary Data Form and the DIGS?”
                                                                 /                      \
                                                             Yes                     No
                                                             /        \
  The record is added to both the Summary         “Add only to the Summary Data Form?”
  Data Form and the DIGS.        /               \
  Summary Data Form (Page 1) appears.                         /                   \

|  Yes                   No
|   /                          \

                                    |            Record is added      Record is added neither
| only to the Summary.        in the Summary Data Form nor
| Data Form.      the DIGS.

                                    |                                    |
                                    |                                    |
An hour glass will appear to indicate the new record is being added.  Wait until the hour glass
disappears and the Summary Data Form is displayed.

4 Enter data in the appropriate forms by navigating from one form to another.  
   See LTo Navigate Between Forms.

LTo Enter Marginal Notes

1 Click the button to the left of Back button.  

 

Marginal Notes Button
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2 Enter marginal notes in the pop-up screen.  Do Not Enter Confidential Information!

Important: For ALL marginal notes being entered into the database, you must enter the question
numbers in reference to the notes.  

LTo Search for a Form By Subject ID

1 Click Edit on the menu bar at the top of the screen to pull down its menu.

2 Click on the Search/Add Form on the pull-down menu.

3 Click By Subject on the Search/Add Form screen.

4 The cursor will be found in the Subject ID box.  Enter the Subject ID in the box.

Can’t place cursor in the Family ID box?  In order to eliminate data entry errors, VISDIGS      
disables the Family ID field when you specify the search by Subject ID.  Click on By Family
to enable the Family ID field.

5 Click the Search button located below the Subject ID box.  Pressing the tab key twice or pressing
the enter key twice on the keyboard will also place the cursor on the Search button from the Subject
ID box.

VISDIGS will display the first page of the Data Summary Form for the subject.  By default,
VISDIGS puts the user  in the Edit mode which allows the user to edit data.  If you are concerned
about accidentally changing or deleting the data, switch to “View Only Mode.”  See LTo Edit or
View Data.  Also see LTo Navigate Between Forms.
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LTo Navigate between Forms

There are two ways to navigate the forms in VISDIGS: use the Sections menu in the menu bar and/or
use the Back and Next buttons located at the bottom of each page.

The Sections menu allows the user to jump from one section or page to another while the Back and
Next buttons allow the user to navigate between two consecutive pages. 

LTo Search for a Form By Family ID

1 Click Edit on the menu bar at the top of the screen.

2 Click on the Search/Add Form on the pull-down menu.

3 Press the  By Family button on the Search/Add Form screen.

4 The cursor will be placed  in the Family ID field. Please enter the Family ID.

Can’t place cursor in the Subject ID box?  In order to eliminate errors, VISDIGS disables the
Subject ID field when you specify the search by Family ID.  You must search either by Subject Id
or Family ID.
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5 Click Search button located below the Family ID box.  Pressing the tab key twice or pressing the
enter key twice on the keyboard will place the cursor on the Search button.

6 Highlight the desired Subject ID on the list by clicking on it to continue.  VISDIGS lists all
subjects under one Family ID: 

LTo Delete a Record

You can delete only one record at a time by Subject ID.

1 Click Edit on the menu bar at the top of the screen.

2 Select  Delete a Subject from the pull-down menu.

3 Enter the Subject ID that you want to delete.

4 Click Delete Record.  Click Yes at the
message prompt if you want to have the
record deleted.
   Click OK when the message prompts
you that the record is deleted.
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LTo Edit or View Data

The mode is reset to default Edit mode each time you press the Search button.  Search and locate
the record first before changing the mode.

1 Click Mode on the menu bar at the top of the screen.

2 Select Edit or View Mode from the pull-down menu.

3 Press the appropriate button.

4 Click OK in the message box.

5 Press the
a p p r o p r i a t e
button and
then click OK
on the “Edit or
View” page.   
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LTo Edit List of
Answer Choices

VISDIGS allows users to
edit the pull-down list of
answer choices in some
cases.  Users may delete or
add to the list by clicking

the Edit button located next to the fields. 

Edit Button

Edit the list from the screen that appears by clicking the Edit button.
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Edit buttons are available for the following fields:

Disease Under Study (Summary Data Form)
Race (Summary Data Form)
Occupation (Page 3, Section A)

LTo Browse Summary Data Form

To check the status of information generally used to draw a family pedigree, use the Browse
Summary Data.

1 Click Mode on the menu bar at the top of the screen.

2 Select Summary Data Browse from the pull-down menu.

3 Enter the Family ID.

4 Press the Browse Family button.

What information can I browse?  You will find the following information displayed on the       
screen: Site ID, Subject ID, Family ID, Father ID, Mother ID, Relation to Proband, Sex, and        
Blood ID.

LTo Create Blood Labels

Labels can be created for blood tubes or other material that needs to be labeled with a subject ID.

1 Click Output under the File menu.

2 Select Blood Labels from the pop-up menu.

3 Press the Enable Fields button on the Blood Labels screen.

Important: You will not be able to enter data in the fields unless you enable the fields by  clicking
Enable Fields.

4 Enter the full range of IDs to print.

5 Click Print Blood Labels.
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6 Click Exit to close the form.

Information: You need to insert Avery 5267 Labels  (½ x 1 3/4 @ 4 columns, 80 per page) into your
printer to print the blood labels.  This information can also be found by pressing the Info button on
the Blood Labels screen.

LTo Export the Data to Text Files

Why do I create text files?  You would create text files if you need to use SAS, SPSS, or           
other analytical application to read the data from the VISDIGS database.  Text files may also be used
to back up your data sets.

1 Click Output menu item under the File menu.

2 Click Export from the Output pop-up menu.

3 The Export Options dialog box should appear.  Check any or all of the three check boxes   
presented.

4 Click the Export button.

The Export routines verify that all required configuration information is available and proceeds to
execute the check boxed options.
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The Export All Data option will create positionally delimited text files for every VISDIGS data
table.  These files will be placed in a temp subdirectory co-located with the VISDIGS program.

The SAS programs option will create text files of SAS programs containing the input statements
and labels for each table.  The input statements should be suitable for creating SAS data sets from
the text files.  NOTE: The default file path delimiter is for Unix operating systems so minor
modifications are needed for PC SAS.

The FTP option will create batch files for zipping (compressing) the text files into one .zip file.  You
will be prompted for the anonymous FTP site that is to receive your data. This file will be sent to the
'incoming' folder of a designated anonymous FTP site. By modifying the VISDIGS.INI file, you can
rename the .zip filename to the user's choosing. 

Export produces output files in a ‘temp’ directory in the same directory as the VISDIGS.MDE file
(usually C:\NEWLOD)

The files in temp will be:

T1.txt through T29.txt  - Text files for DIGS sections

T1.sas through T29.sas  - SAS input satements

PEDIGREE.TXT - Text file of Data Summary Form

TBLMNOTES.TXT - Text file of all marginal notes

TBLMNOTES.SAS - - SAS input statment to read in marginal notes

From the Access help menu

Remove a Database Password

1. On the File menu, click Open Database.
2. Select the Exclusive check box, and then open the database.
3. In the Password Required dialog box, type the database password, and then click OK.

Passwords are case-sensitive.
4. On the Tools menu, point to Security, and then click Unset Database Password. This

command is only available if a database password was set previously.
5. In the Unset Database Password dialog box, type your current password. 
6. Click OK.

Protect a Database by Adding a Database Password
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1. Close the database. If the database is shared on a network, ask all other users to close
the database.

2. Make a backup copy of the database and store it in a secure place.
3. On the File menu, click Open Database.
4. Select the Exclusive check box, and then open the database.
5. On the Tools menu, point to Security, and then click Set Database Password.
6. In the Password box, type your password. Passwords are case-sensitive.
7. In the Verify box, confirm your password by typing the password again, and then

click OK.

The password is now set. The next time you or any other user opens the database, a dialog
box will be displayed that requests a password.

Caution

1. If you lose or forget your password, it can't be recovered and you won't be able to
open your database.

2. Do not use a database password if you will be replicating a database. Replicated
databases can't be synchronized if database passwords are defined. 

Notes

1. If you need more extensive security than that provided by a database password, you
need to define user-level security. For information, click.

2. You can't set a database password if user-level security has been defined for your
database and you don't have Administer permission for the database. Also, a database
password is defined in addition to user-level security. If user-level security has been
defined, any restrictions based on user-level security permissions remain in effect.

3. If a table from a password-protected database is linked, the password is cached
(saved) in the database it is linked to when the link is established. This may have
unforeseen consequences. For more information, click.

LAdditional Codes

These diagnosis codes are available for each diagnostic system.

"60","Undiagnosed and unspecified mental disorder"
"61","Unknown psychotic disorder, without hospitalization"
"62","Unknown psychotic disorder, with hospitalization"
"63","Diagnosed but unspecified mental disorder, without hospitalization"
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"64","Diagnosed but unspecified mental disorder, with hospitalization"
"90","Never mentally ill"
"97","Other diagnoses without hospitalization"
"98","Other diagnoses with hospitalization"


